From 389917c0030a3f62a527b608261d7b66bf291b22 Mon Sep 17 00:00:00 2001 From: Steve McIntyre Date: Fri, 5 Jul 2019 18:26:43 +0100 Subject: [PATCH] Change a load of http URLs to use https instead --- CONF.sh | 12 +++---- Makefile | 2 +- README | 6 ++-- data/buster/README.html.in | 64 +++++++++++++++++------------------ data/jessie/README.html.in | 62 ++++++++++++++++----------------- data/stretch/README.html.in | 62 ++++++++++++++++----------------- debian/changelog | 7 ++++ tools/buster/installtools.sh | 2 +- tools/jessie/installtools.sh | 2 +- tools/jigdo_cleanup | 4 +-- tools/stretch/installtools.sh | 2 +- tools/update_popcon | 2 +- update-cd | 2 +- 13 files changed, 118 insertions(+), 111 deletions(-) diff --git a/CONF.sh b/CONF.sh index a5029257..08e36dc8 100644 --- a/CONF.sh +++ b/CONF.sh @@ -91,7 +91,7 @@ export DEBVERSION="10.0.0" # Official or non-official set. # NOTE: THE "OFFICIAL" DESIGNATION IS ONLY ALLOWED FOR IMAGES AVAILABLE -# ON THE OFFICIAL DEBIAN CD WEBSITE http://cdimage.debian.org +# ON THE OFFICIAL DEBIAN CD WEBSITE https://cdimage.debian.org export OFFICIAL="Unofficial" #export OFFICIAL="Official" #export OFFICIAL="Official Beta" @@ -273,7 +273,7 @@ export IMAGESUMS=1 # sources) available somewhere, list it here so that README.source # can point to it. Note that your mirror must have repositories of # source packages if you enable this option. -# export ARCHIVE_EXTRACTED_SOURCES="http://cdimage.debian.org/cdimage/cd-sources/" +# export ARCHIVE_EXTRACTED_SOURCES="https://cdimage.debian.org/cdimage/cd-sources/" # Produce iso/jigdo files: specify how many iso/jigdo files should be # produced in your set. If not set or when the value is "ALL" they will @@ -308,7 +308,7 @@ export IMAGESUMS=1 # The included files are used to provide an up-to-date list of Debian # mirrors to the jigdo _GUI_application_ (_jigdo-lite_ doesn't support # "[Include ...]"). -export JIGDOINCLUDEURLS="http://cdimage.debian.org/debian-cd/debian-servers.jigdo" +export JIGDOINCLUDEURLS="https://cdimage.debian.org/debian-cd/debian-servers.jigdo" # # $JIGDOTEMPLATEURL and $JIGDOINCLUDEURLS are passed to # "tools/jigdo_header", which is used by default to generate the @@ -320,7 +320,7 @@ export JIGDOINCLUDEURLS="http://cdimage.debian.org/debian-cd/debian-servers.jigd # A couple of things used only by publish_cds, so it can tweak the # jigdo files, and knows where to put the results. # You need to run publish_cds manually, it is not run by the Makefile. -export PUBLISH_URL="http://cdimage.debian.org/jigdo-area" +export PUBLISH_URL="https://cdimage.debian.org/jigdo-area" export PUBLISH_PATH="/home/jigdo-area/" # Specify files and directories to *exclude* from jigdo processing. These @@ -349,7 +349,7 @@ done # Base link for snapshot.debian.org or similar # "SNAPDATETIME" will be replaced at runtime with the correct data # Leave this unset to not add this entry -export SNAPURL=Debian=http://snapshot.debian.org/archive/debian/SNAPDATETIME/ +export SNAPURL=Debian=https://snapshot.debian.org/archive/debian/SNAPDATETIME/ # File with list of packages to include when fetching modules for the # first stage installer (debian-installer). One package per line. @@ -402,7 +402,7 @@ export SNAPURL=Debian=http://snapshot.debian.org/archive/debian/SNAPDATETIME/ export OMIT_RELEASE_NOTES=1 # Set this to override the default location -#export RELEASE_NOTES_LOCATION="http://www.debian.org/releases/$CODENAME" +#export RELEASE_NOTES_LOCATION="https://www.debian.org/releases/$CODENAME" # Set to 1 to not include the doc/tools directories on CD1 # Useful to save space and avoids failures if you have a mirror diff --git a/Makefile b/Makefile index 8807a0ee..5326970e 100755 --- a/Makefile +++ b/Makefile @@ -387,7 +387,7 @@ $(BDIR)/rawlist: # Dirty workaround for saving space, we add some hints to break ties. # This is just a temporal solution, sort_deps should be a little bit less # silly so that this is not needed. For more info have a look at -# http://lists.debian.org/debian-cd/2004/debian-cd-200404/msg00093.html +# https://lists.debian.org/debian-cd/2004/debian-cd-200404/msg00093.html $(Q)if [ "$(SOURCEONLY)"x != "yes"x ] ; then \ if [ "$(INSTALLER_CD)"x = "1"x ] ; then \ : ; \ diff --git a/README b/README index 042af84e..e6225326 100644 --- a/README +++ b/README @@ -2,7 +2,7 @@ debian-cd ========= Copyright 1999-2001 Raphaël Hertzog and others, -2004-2010 Steve McIntyre +2004-2019 Steve McIntyre This set of tools is licensed under the General Public License version 2 or any later version. You can find it in /usr/share/common-licenses/GPL on a Debian GNU system. @@ -266,7 +266,7 @@ Jigdo ----- You may also want to make the CD images available in jigdo format. Jigsaw Download, the successor to the Pseudo-Image Kit. -See http://www.debian.org/CD/jigdo-cd/ for more information on jigdo. +See https://www.debian.org/CD/jigdo-cd/ for more information on jigdo. Set the DOJIGDO and related variables in CONF.sh. This is no separate target for jigdo, merely a modification of the "images" targets. You can choose @@ -332,4 +332,4 @@ images. Don't use it for ISO images that will used by many users. Note that you will also need a patched mkhybrid that does support the -F option. Have a look here about it : -http://www.chiark.greenend.org.uk/~stevem/DebianCD/ +https://www.chiark.greenend.org.uk/~stevem/DebianCD/ diff --git a/data/buster/README.html.in b/data/buster/README.html.in index 87e3f117..911698c9 100644 --- a/data/buster/README.html.in +++ b/data/buster/README.html.in @@ -15,7 +15,7 @@ - + #if 0 If you read THIS, you're viewing the actual source file ;-) #endif @@ -44,7 +44,7 @@ #if OUTPUThtml
@@ -78,11 +78,11 @@ #else

This is one disc in a set containing the #endif - Debian DEBIAN_KERNEL distribution. + Debian DEBIAN_KERNEL distribution. Debian is a very extensive collection of software. But it is more. It is a complete Operating System (OS) for your computer. And it is free (as in + "https://www.debian.org/intro/free">free (as in “freedom”).

@@ -122,23 +122,23 @@ the kernel. The kernel is the most fundamental program on the computer, which does all the basic housekeeping and lets you start other programs. Debian is kernel independent. It currently uses - either the Linux - or FreeBSD kernel. Most of + either the Linux + or FreeBSD kernel. Most of the basic operating system tools come from the GNU project; hence the name + "https://www.gnu.org/">GNU project; hence the name DEBIAN_KERNEL.

Debian is available for various kinds of computers (“architectures”). Check the - ports page for more + ports page for more information.

#if OUTPUTtext

Read more at:
 
-   http://www.debian.org/intro/about

+   https://www.debian.org/intro/about

#endif #if OUTPUThtml -

Read more...

+

Read more...

#endif

@@ -185,7 +185,7 @@ # if (OFFICIAL_VAL == 2) # if OMIT_RELEASE_NOTES

The Release Notes for "buster" are available on the - Debian web + Debian web site.

# else # if DISKNUM == 1 @@ -193,7 +193,7 @@ in /doc/release-notes/, in several languages. Additional translations and updated versions for the Release Notes may be available from the - Debian web + Debian web site.

# else

See the first disc in this set for the "buster" Release Notes.

@@ -210,7 +210,7 @@

This disc includes non-free firmware to make installation easier on some systems requiring proprietary but redistributable firmware. See - http://wiki.debian.org/Firmware + https://wiki.debian.org/Firmware for more details.

@@ -236,7 +236,7 @@ # if (OFFICIAL_VAL == 2) # if OMIT_MANUAL

An Installation Guide for this disc is available from - the + the Debian web site.

# else

An Installation Guide is included on this disc at @@ -249,15 +249,15 @@

Note: additional translations, other formats (like PDF and TXT) and updated versions for the Installation Guide are available from - the Debian web site. + the Debian web site.

# endif # else

As this is not an official buster release disc, then the installation guide many not be released yet. It will appear on the + href="https://www.debian.org/releases/buster/installmanual">the Debian web site when ready, but before then you could try the development + href="https://d-i.alioth.debian.org/manual/">the development version of the manual.

# endif @@ -299,12 +299,12 @@ development version of the Debian system. This means that all sorts of bugs may be present anywhere in the system. Please report any bugs you find in the Debian Bug Tracking System; details at bugs.debian.org. + href="https://bugs.debian.org/">bugs.debian.org. #endif # if (OFFICIAL_VAL == 2)
  • This is an official release of the Debian system. Please report any bugs you find in the Debian Bug Tracking System; details at bugs.debian.org. + HREF="https://bugs.debian.org/">bugs.debian.org. #endif
  • If you're reporting bugs against this disc or the installation system, please also mention the version of this disc; this can be found @@ -366,7 +366,7 @@ #ifdef OUTPUTtext   #endif - http://www.debian.org/CD/ + https://www.debian.org/CD/

    #endif @@ -434,37 +434,37 @@ @@ -480,9 +480,9 @@

    #endif See the Debian contact page + "https://www.debian.org/contact">contact page #if OUTPUTtext - (http://www.debian.org/contact) + (https://www.debian.org/contact) #endif for information on contacting us.

    diff --git a/data/jessie/README.html.in b/data/jessie/README.html.in index 19af093d..edc2ada7 100644 --- a/data/jessie/README.html.in +++ b/data/jessie/README.html.in @@ -44,7 +44,7 @@ #if OUTPUThtml
    @@ -78,11 +78,11 @@ #else

    This is one disc in a set containing the #endif - Debian DEBIAN_KERNEL distribution. + Debian DEBIAN_KERNEL distribution. Debian is a very extensive collection of software. But it is more. It is a complete Operating System (OS) for your computer. And it is free (as in + "https://www.debian.org/intro/free">free (as in “freedom”).

    @@ -122,25 +122,25 @@ the kernel. The kernel is the most fundamental program on the computer, which does all the basic housekeeping and lets you start other programs. Debian is kernel independent. It currently uses - either the Linux - or FreeBSD kernel. Most of + either the Linux + or FreeBSD kernel. Most of the basic operating system tools come from the GNU project; hence the name + "https://www.gnu.org/">GNU project; hence the name DEBIAN_KERNEL.

    Debian is available for various kinds of computers (“architectures”), like “IBM-compatible” PCs (i386), Compaq's Alpha, Sun's Sparc, Motorola/IBM's PowerPC, and (Strong)ARM processors. Check the - ports page for more + ports page for more information.

    #if OUTPUTtext

    Read more at:
     
    -   http://www.debian.org/intro/about

    +   https://www.debian.org/intro/about

    #endif #if OUTPUThtml -

    Read more...

    +

    Read more...

    #endif

    @@ -187,7 +187,7 @@ # if (OFFICIAL_VAL == 2) # if OMIT_RELEASE_NOTES

    The Release Notes for "jessie" are available on the - Debian web + Debian web site.

    # else # if DISKNUM == 1 @@ -195,7 +195,7 @@ in /doc/release-notes/, in several languages. Additional translations and updated versions for the Release Notes may be available from the - Debian web + Debian web site.

    # else

    See the first disc in this set for the "jessie" Release Notes.

    @@ -212,7 +212,7 @@

    This disc includes non-free firmware to make installation easier on some systems requiring proprietary but redistributable firmware. See - http://wiki.debian.org/Firmware + https://wiki.debian.org/Firmware for more details.

    @@ -238,7 +238,7 @@ # if (OFFICIAL_VAL == 2) # if OMIT_MANUAL

    An Installation Guide for this disc is available from - the + the Debian web site.

    # else

    An Installation Guide is included on this disc at @@ -251,15 +251,15 @@

    Note: additional translations, other formats (like PDF and TXT) and updated versions for the Installation Guide are available from - the Debian web site. + the Debian web site.

    # endif # else

    As this is not an official jessie release disc, then the installation guide many not be released yet. It will appear on the + href="https://www.debian.org/releases/jessie/installmanual">the Debian web site when ready, but before then you could try the development + href="https://d-i.alioth.debian.org/manual/">the development version of the manual.

    # endif @@ -301,12 +301,12 @@ development version of the Debian system. This means that all sorts of bugs may be present anywhere in the system. Please report any bugs you find in the Debian Bug Tracking System; details at bugs.debian.org.

  • + href="https://bugs.debian.org/">bugs.debian.org. #endif # if (OFFICIAL_VAL == 2)
  • This is an official release of the Debian system. Please report any bugs you find in the Debian Bug Tracking System; details at bugs.debian.org. + HREF="https://bugs.debian.org/">bugs.debian.org. #endif
  • If you're reporting bugs against this disc or the installation system, please also mention the version of this disc; this can be found @@ -368,7 +368,7 @@ #ifdef OUTPUTtext   #endif - http://www.debian.org/CD/ + https://www.debian.org/CD/

    #endif @@ -436,37 +436,37 @@ @@ -482,9 +482,9 @@

    #endif See the Debian contact page + "https://www.debian.org/contact">contact page #if OUTPUTtext - (http://www.debian.org/contact) + (https://www.debian.org/contact) #endif for information on contacting us.

    diff --git a/data/stretch/README.html.in b/data/stretch/README.html.in index aa725eec..af91b862 100644 --- a/data/stretch/README.html.in +++ b/data/stretch/README.html.in @@ -44,7 +44,7 @@ #if OUTPUThtml
    @@ -78,11 +78,11 @@ #else

    This is one disc in a set containing the #endif - Debian DEBIAN_KERNEL distribution. + Debian DEBIAN_KERNEL distribution. Debian is a very extensive collection of software. But it is more. It is a complete Operating System (OS) for your computer. And it is free (as in + "https://www.debian.org/intro/free">free (as in “freedom”).

    @@ -122,23 +122,23 @@ the kernel. The kernel is the most fundamental program on the computer, which does all the basic housekeeping and lets you start other programs. Debian is kernel independent. It currently uses - either the Linux - or FreeBSD kernel. Most of + either the Linux + or FreeBSD kernel. Most of the basic operating system tools come from the GNU project; hence the name + "https://www.gnu.org/">GNU project; hence the name DEBIAN_KERNEL.

    Debian is available for various kinds of computers (“architectures”). Check the - ports page for more + ports page for more information.

    #if OUTPUTtext

    Read more at:
     
    -   http://www.debian.org/intro/about

    +   https://www.debian.org/intro/about

    #endif #if OUTPUThtml -

    Read more...

    +

    Read more...

    #endif

    @@ -185,7 +185,7 @@ # if (OFFICIAL_VAL == 2) # if OMIT_RELEASE_NOTES

    The Release Notes for "stretch" are available on the - Debian web + Debian web site.

    # else # if DISKNUM == 1 @@ -193,7 +193,7 @@ in /doc/release-notes/, in several languages. Additional translations and updated versions for the Release Notes may be available from the - Debian web + Debian web site.

    # else

    See the first disc in this set for the "stretch" Release Notes.

    @@ -210,7 +210,7 @@

    This disc includes non-free firmware to make installation easier on some systems requiring proprietary but redistributable firmware. See - http://wiki.debian.org/Firmware + https://wiki.debian.org/Firmware for more details.

    @@ -236,7 +236,7 @@ # if (OFFICIAL_VAL == 2) # if OMIT_MANUAL

    An Installation Guide for this disc is available from - the + the Debian web site.

    # else

    An Installation Guide is included on this disc at @@ -249,15 +249,15 @@

    Note: additional translations, other formats (like PDF and TXT) and updated versions for the Installation Guide are available from - the Debian web site. + the Debian web site.

    # endif # else

    As this is not an official stretch release disc, then the installation guide many not be released yet. It will appear on the + href="https://www.debian.org/releases/stretch/installmanual">the Debian web site when ready, but before then you could try the development + href="https://d-i.alioth.debian.org/manual/">the development version of the manual.

    # endif @@ -299,12 +299,12 @@ development version of the Debian system. This means that all sorts of bugs may be present anywhere in the system. Please report any bugs you find in the Debian Bug Tracking System; details at bugs.debian.org.

  • + href="https://bugs.debian.org/">bugs.debian.org. #endif # if (OFFICIAL_VAL == 2)
  • This is an official release of the Debian system. Please report any bugs you find in the Debian Bug Tracking System; details at bugs.debian.org. + HREF="https://bugs.debian.org/">bugs.debian.org. #endif
  • If you're reporting bugs against this disc or the installation system, please also mention the version of this disc; this can be found @@ -366,7 +366,7 @@ #ifdef OUTPUTtext   #endif - http://www.debian.org/CD/ + https://www.debian.org/CD/

    #endif @@ -434,37 +434,37 @@ @@ -480,9 +480,9 @@

    #endif See the Debian contact page + "https://www.debian.org/contact">contact page #if OUTPUTtext - (http://www.debian.org/contact) + (https://www.debian.org/contact) #endif for information on contacting us.

    diff --git a/debian/changelog b/debian/changelog index 9612495f..dd284d35 100644 --- a/debian/changelog +++ b/debian/changelog @@ -1,3 +1,10 @@ +debian-cd (3.1.25) UNRELEASED; urgency=medium + + [ Steve McIntyre ] + * Change a load of http URLs to use https instead, + + -- Steve McIntyre <93sam@debian.org> Wed, 26 Jun 2019 18:26:02 +0100 + debian-cd (3.1.25) unstable; urgency=medium [ Steve McIntyre ] diff --git a/tools/buster/installtools.sh b/tools/buster/installtools.sh index 8a726788..9ecdf688 100755 --- a/tools/buster/installtools.sh +++ b/tools/buster/installtools.sh @@ -4,7 +4,7 @@ set -e if [ "$RELEASE_NOTES_LOCATION"x = ""x ] ; then - export RELEASE_NOTES_LOCATION="http://www.debian.org/releases/$CODENAME" + export RELEASE_NOTES_LOCATION="https://www.debian.org/releases/$CODENAME" fi # The location of the tree for CD#1, passed in diff --git a/tools/jessie/installtools.sh b/tools/jessie/installtools.sh index a8ac4b5d..0acaea4c 100755 --- a/tools/jessie/installtools.sh +++ b/tools/jessie/installtools.sh @@ -4,7 +4,7 @@ set -e if [ "$RELEASE_NOTES_LOCATION"x = ""x ] ; then - export RELEASE_NOTES_LOCATION="http://www.debian.org/releases/$CODENAME" + export RELEASE_NOTES_LOCATION="https://www.debian.org/releases/$CODENAME" fi # The location of the tree for CD#1, passed in diff --git a/tools/jigdo_cleanup b/tools/jigdo_cleanup index eeed1798..b792d524 100755 --- a/tools/jigdo_cleanup +++ b/tools/jigdo_cleanup @@ -15,7 +15,7 @@ iso="$2" # The name to give to the .iso dirpath="$3" # The disc build tree template="$4" # URL for .template file, can be relative URL discinfo="$5" # e.g. "Debian GNU/Linux 3.0 r1 "Woody" - Unofficial i386 Binary-1" -snapurl="$6" # URL for snapshot.d.o. e.g. http://snapshot.debian.org/archive/debian/20110630T000000Z/ +snapurl="$6" # URL for snapshot.d.o. e.g. https://snapshot.debian.org/archive/debian/20110630T000000Z/ # any further parameters are fallback URLs info="Generated on "`date -R` @@ -42,7 +42,7 @@ mv -f $jigdo.1 $jigdo # If some fallbacks were specified, output a servers section with the # URLs. The entries of the variable are expected to be already of the -# form "Label=http://some.url/" +# form "Label=https://some.url/" if test -n "$JIGDOFALLBACKURLS"; then for url in "$JIGDOFALLBACKURLS" do diff --git a/tools/stretch/installtools.sh b/tools/stretch/installtools.sh index 3e6203cf..83e25ac2 100755 --- a/tools/stretch/installtools.sh +++ b/tools/stretch/installtools.sh @@ -4,7 +4,7 @@ set -e if [ "$RELEASE_NOTES_LOCATION"x = ""x ] ; then - export RELEASE_NOTES_LOCATION="http://www.debian.org/releases/$CODENAME" + export RELEASE_NOTES_LOCATION="https://www.debian.org/releases/$CODENAME" fi # The location of the tree for CD#1, passed in diff --git a/tools/update_popcon b/tools/update_popcon index 19af2486..01685e27 100755 --- a/tools/update_popcon +++ b/tools/update_popcon @@ -36,7 +36,7 @@ dl_file () { # We've had problems in the past with download failures causing issues, # so let's make sure that we get the complete file in each case DIST=$1 - SITE="http://popcon.debian.org/" + SITE="https://popcon.debian.org/" curl -L $capath -s --head $SITE/$DIST/by_inst > $TDIR/$DIST.head error=$? diff --git a/update-cd b/update-cd index 9744195b..acfd7d9e 100755 --- a/update-cd +++ b/update-cd @@ -43,7 +43,7 @@ CODENAME=stretch OUT=/srv/cdbuilder.debian.org/src/deb-cd/tmp/stretch-update/cd-out # Location(s) for the snapshot(s) -SNAPSHOT='Debian=http://us.cdimage.debian.org/cdimage/snapshot/Debian/ --try-last' +SNAPSHOT='Debian=https://us.cdimage.debian.org/cdimage/snapshot/Debian/ --try-last' # Type of disc image, cd or dvd (lower case) if [ "$1"x = ""x ] ; then