diff --git a/debian/changelog b/debian/changelog
index 7687dcf4..ccfbd628 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ debian-cd (2.2.20) UNRELEASED; urgency=low
   * Joey Hess
     - Remove bogus init=/linuxrc, we have not had a linuxrc in d-i for a long
       time and I don't know how that managed to work.
+    - Update path to ia64 cdrom/boot.img.
 
  -- Joey Hess <joeyh@debian.org>  Mon, 30 Aug 2004 15:23:19 -0400
 
diff --git a/tools/boot/sarge/boot-ia64 b/tools/boot/sarge/boot-ia64
index 6e8de284..082f6cc7 100755
--- a/tools/boot/sarge/boot-ia64
+++ b/tools/boot/sarge/boot-ia64
@@ -32,9 +32,9 @@ fi
 for image in boot.img; do
     if [ ! -e "$image" ]; then
 	if [ ! "$DI_WWW_HOME" ];then
-		cp "$MIRROR/dists/$DI_DIST/main/installer-$ARCH/current/images/$image" .
+		cp "$MIRROR/dists/$DI_DIST/main/installer-$ARCH/current/images/cdrom/$image" .
 	else
-		wget "$DI_WWW_HOME/$image"
+		wget "$DI_WWW_HOME/cdrom/$image"
 	fi
     fi
 done