diff --git a/Makefile b/Makefile
index 4744eaab..58e7e568 100755
--- a/Makefile
+++ b/Makefile
@@ -586,12 +586,14 @@ $(SDIR)/CD1/README.html:
$$dir/README.mirrors.html $$dir/README.non-US; \
cpp -traditional -undef -P -C -Wall -nostdinc -I $$dir/ \
-D OMIT_MANUAL="$(OMIT_MANUAL)" \
+ -D OFFICIAL=$(OFFICIAL) \
-D OUTPUTtext $(BASEDIR)/data/$(CODENAME)/README.html.in \
| sed -e 's/%%.//g' > $$dir/README.html ; \
lynx -dump -force_html $$dir/README.html | todos \
> $$dir/README.txt ; \
cpp -traditional -undef -P -C -Wall -nostdinc -I $$dir/ \
-D OMIT_MANUAL="$(OMIT_MANUAL)" \
+ -D OFFICIAL=$(OFFICIAL) \
-D OUTPUThtml $(BASEDIR)/data/$(CODENAME)/README.html.in \
| sed -e 's/%%.//g' > $$dir/README.html ; \
rm -f $$dir/README.diskdefines ; \
diff --git a/data/etch/README.html.in b/data/etch/README.html.in
index 87e68ac4..a9c94114 100644
--- a/data/etch/README.html.in
+++ b/data/etch/README.html.in
@@ -432,6 +432,7 @@ Last-Minute Notes
#endif
+#if OFFICIAL != Official
@@ -443,16 +444,9 @@ bugs may be present anywhere in the system.
-#if 0
--------- This can't be an official image, so also no official notes.
--
-Last-minutes notes for this CD may be available on
-http://www.debian.org/CD/releases/
-
-#endif
-
#endif
+#endif
#if TYPEbinary
#if OUTPUTtext
diff --git a/data/sarge/README.html.in b/data/sarge/README.html.in
index c5164b67..bbcf1453 100644
--- a/data/sarge/README.html.in
+++ b/data/sarge/README.html.in
@@ -432,6 +432,7 @@ Last-Minute Notes
#endif
+#if OFFICIAL != Official
@@ -443,16 +444,9 @@ bugs may be present anywhere in the system.
-#if 0
--------- This can't be an official image, so also no official notes.
--
-Last-minutes notes for this CD may be available on
-http://www.debian.org/CD/releases/
-
-#endif
-
#endif
+#endif
#if TYPEbinary
#if OUTPUTtext
diff --git a/debian/changelog b/debian/changelog
index 43948404..c6e11ba7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -120,6 +120,9 @@ debian-cd (2.2.25) UNRELEASED; urgency=low
* Add more features to get_diskusage.pl, making it easier to track
dependencies and rejected packages.
+ [ Steve McIntyre ]
+ * Try to fix the "unofficial development version" bug on official CDs.
+
-- Frans Pop Wed, 2 Aug 2006 16:47:57 +0200
debian-cd (2.2.24) unstable; urgency=low
diff --git a/tools/add-bin-doc b/tools/add-bin-doc
index 17dc7c74..5c39c6d5 100755
--- a/tools/add-bin-doc
+++ b/tools/add-bin-doc
@@ -35,6 +35,7 @@ for i in $BDIR/*.packages; do
cpp -traditional -undef -P -C -Wall -nostdinc -I$dir \
-D OMIT_MANUAL="$OMIT_MANUAL" \
-D OMIT_RELEASE_NOTES="$OMIT_RELEASE_NOTES" \
+ -D OFFICIAL="$OFFICIAL" \
-D OUTPUTtext $BASEDIR/data/$CODENAME/README.html.in \
| sed -e 's/%%.//g' > $dir/README.html
@@ -44,6 +45,7 @@ for i in $BDIR/*.packages; do
cpp -traditional -undef -P -C -Wall -nostdinc -I $dir/ \
-D OMIT_MANUAL="$OMIT_MANUAL" \
-D OMIT_RELEASE_NOTES="$OMIT_RELEASE_NOTES" \
+ -D OFFICIAL="$OFFICIAL" \
-D OUTPUThtml $BASEDIR/data/$CODENAME/README.html.in \
| sed -e 's/%%.//g' > $dir/README.html