diff --git a/squeeze/data/squeeze/README.html.in b/squeeze/data/squeeze/README.html.in
index 9fe233c1..df7bc8d4 100644
--- a/squeeze/data/squeeze/README.html.in
+++ b/squeeze/data/squeeze/README.html.in
@@ -3,8 +3,8 @@
- Debian GNU/Linux -- The Universal Operating System
-
+ Debian DEBIAN_KERNEL -- The Universal Operating System
+
@@ -70,7 +70,7 @@
#endif
#if (defined(DISKTYPEBC) || defined(DISKTYPENETINST))
@@ -78,7 +78,7 @@
#else
This is one disc in a set containing the
#endif
- Debian GNU/Linux distribution.
+ Debian DEBIAN_KERNEL distribution.
Debian is a very extensive collection of software. But it
is more. It is a complete Operating System (OS) for your
computer. And it is
- An operating system is the set of basic programs and
- utilities that make your computer run. At the core of an
- operating system is the kernel. The kernel is the most
- fundamental program on the computer, which does all the basic
- housekeeping and lets you start other programs. Debian is
- kernel independent. It currently uses the Linux kernel but work is in
- progress to provide Debian for other kernels, using the Hurd. Most
- of the basic operating system tools come from the An operating system is the set of basic programs and utilities
+ that make your computer run. At the core of an operating system is
+ the kernel. The kernel is the most fundamental program on the
+ computer, which does all the basic housekeeping and lets you start
+ other programs. Debian is kernel independent. It currently uses
+ either the Linux
+ or FreeBSD kernel. Most of
+ the basic operating system tools come from the GNU project; hence the name
- GNU/Linux.
+ DEBIAN_KERNEL.
Debian is available for various kinds of computers
(“architectures”), like “IBM-compatible” PCs (i386),
@@ -193,7 +191,7 @@
site.
# else
# if DISKNUM == 1
- The Release Notes for Debian GNU/Linux "squeeze" are included on this disc
+
The Release Notes for Debian DEBIAN_KERNEL "squeeze" are included on this disc
in /doc/release-notes/, in
several languages. Additional translations and updated versions for
the Release Notes may be available from the
@@ -235,7 +233,7 @@
#if TYPEbinary
Because Debian is a complete Operating System, the
installation procedure may seem a bit unusual. You can install
- Debian GNU/Linux either alongside your current OS, or as
+ Debian DEBIAN_KERNEL either alongside your current OS, or as
the only OS on your computer.
# if (OFFICIAL_VAL == 2)
# if OMIT_MANUAL
@@ -360,7 +358,7 @@
You are completely free to manufacture and re-distribute CDs/DVDs of the
- Debian GNU/Linux Operating System, like this one. There is no charge from
+ Debian DEBIAN_KERNEL Operating System, like this one. There is no charge from
us (but of course donations are always welcome).
For all needed information and contact addresses, please
diff --git a/squeeze/debian/changelog b/squeeze/debian/changelog
index 6cdb8d66..4c73627c 100644
--- a/squeeze/debian/changelog
+++ b/squeeze/debian/changelog
@@ -53,6 +53,8 @@ debian-cd (3.1.6) UNRELEASED-backport; urgency=low
* Add an extra tweaked version of d390.ins for s390 booting. The
Hardware Management Console needs the file to be in the root
directory.
+ * Describe discs appropriately depending on the kernel used.
+ Closes: #673975
-- Raphaƫl Hertzog Fri, 04 Feb 2011 09:59:21 +0100
diff --git a/squeeze/tools/add-bin-doc b/squeeze/tools/add-bin-doc
index f1fea01f..b3691fba 100755
--- a/squeeze/tools/add-bin-doc
+++ b/squeeze/tools/add-bin-doc
@@ -55,6 +55,7 @@ cpp -traditional -undef -P -C -Wall -nostdinc -I$dir \
-D OMIT_MANUAL="$OMIT_MANUAL" \
-D OFFICIAL_VAL=$OFFICIAL_VAL \
-D OMIT_RELEASE_NOTES="$OMIT_RELEASE_NOTES" \
+ -D DEBIAN_KERNEL="$DEBIAN_KERNEL" \
-D OUTPUTtext $BASEDIR/data/$CODENAME/README.html.in \
| sed -e 's/%%.//g' > $dir/README.html
@@ -68,6 +69,7 @@ cpp -traditional -undef -P -C -Wall -nostdinc -I $dir/ \
-D OMIT_MANUAL="$OMIT_MANUAL" \
-D OFFICIAL_VAL=$OFFICIAL_VAL \
-D OMIT_RELEASE_NOTES="$OMIT_RELEASE_NOTES" \
+ -D DEBIAN_KERNEL="$DEBIAN_KERNEL" \
-D OUTPUThtml $BASEDIR/data/$CODENAME/README.html.in \
| sed -e 's/%%.//g' > $dir/README.html
diff --git a/squeeze/tools/start_new_disc b/squeeze/tools/start_new_disc
index fe19a1e9..915cd658 100755
--- a/squeeze/tools/start_new_disc
+++ b/squeeze/tools/start_new_disc
@@ -25,6 +25,12 @@ DI_DATA_DIR=$BASEDIR/data/$DI_CODENAME
CAPCODENAME=`perl -e "print ucfirst("$CODENAME")"`
NUM_ARCHES=`echo $ARCHES | wc -w`
+case "$ARCHES" in
+ *kfreebsd*) DEBIAN_KERNEL="GNU/kFreeBSD";;
+ *hurd*) DEBIAN_KERNEL="GNU/Hurd";;
+ *) DEBIAN_KERNEL="GNU/Linux";;
+esac
+export DEBIAN_KERNEL
if [ "$VOLID_BASE"x = ""x ] ; then
VOLID_BASE="Debian $DEBVERSION"
@@ -34,13 +40,13 @@ if [ $NUM_ARCHES = 1 ] ; then
case $ARCHES in
source)
SOURCEDISK=1
- export DISKINFO="Debian GNU/Linux $DEBVERSION \"$CAPCODENAME\" - $OFFICIAL $DISKTYPE Source-$DISKNUM $BUILD_DATE"
+ export DISKINFO="Debian $DEBVERSION \"$CAPCODENAME\" - $OFFICIAL $DISKTYPE Source-$DISKNUM $BUILD_DATE"
export VOLID="$VOLID_BASE Source $DISKNUM"
export SOURCEONLY=yes
;;
*)
BINARYDISK=1
- export DISKINFO="Debian GNU/Linux $DEBVERSION \"$CAPCODENAME\" - $OFFICIAL $ARCHES $DISKTYPE Binary-$DISKNUM $BUILD_DATE"
+ export DISKINFO="Debian ${DEBIAN_KERNEL} $DEBVERSION \"$CAPCODENAME\" - $OFFICIAL $ARCHES $DISKTYPE Binary-$DISKNUM $BUILD_DATE"
case "$ARCHES" in
powerpc)
export VOLID="$VOLID_BASE ppc $DISKNUM" ;;
@@ -60,7 +66,7 @@ else
*source*) SOURCEDISK=1;;
esac
export ARCHDEF=`echo $ARCHES | sed 's? ?/?g'`
- export DISKINFO="Debian GNU/Linux $DEBVERSION \"$CAPCODENAME\" - $OFFICIAL Multi-architecture $ARCHDEF $DISKTYPE #$DISKNUM $BUILD_DATE"
+ export DISKINFO="Debian ${DEBIAN_KERNEL} $DEBVERSION \"$CAPCODENAME\" - $OFFICIAL Multi-architecture $ARCHDEF $DISKTYPE #$DISKNUM $BUILD_DATE"
export VOLID="$VOLID_BASE M-A $DISKNUM"
fi
diff --git a/squeeze/update-cd b/squeeze/update-cd
index fcb3b6ae..0051e57d 100755
--- a/squeeze/update-cd
+++ b/squeeze/update-cd
@@ -171,7 +171,7 @@ make_cd () {
${JIGDODIR}/${BASENAME}.jigdo \
${BASENAME}.iso \
$OUT ${BASENAME}.template \
- "Debian GNU/Linux $VER - $OFFICIAL $THISARCH $FIRSTVER->$VER update $TYPEUP #$THISNUM"
+ "Debian ${DEBIAN_KERNEL} $VER - $OFFICIAL $THISARCH $FIRSTVER->$VER update $TYPEUP #$THISNUM"
echo $SNAPSHOT >> ${JIGDODIR}/${BASENAME}.jigdo
# Make sure that the ISO is as new/newer than the jigdo file; #587774
touch ${ISODIR}/${BASENAME}.iso
@@ -244,7 +244,7 @@ start_new_disc () {
echo "Creating $TYPEUP$CDNUM for binary-$THISARCH (part $THISNUM)"
fi
mkdir $UPD/CD$CDNUM $UPD/CD$CDNUM/.disk
- INFO="Debian GNU/Linux $VER Update $TYPEUP $DATE: $THISARCH $TYPEUP $THISNUM"
+ INFO="Debian ${DEBIAN_KERNEL} $VER Update $TYPEUP $DATE: $THISARCH $TYPEUP $THISNUM"
echo $INFO > $UPD/CD$CDNUM/.disk/info
SIZE_USED=0
SRCFILES=0
@@ -279,6 +279,14 @@ do
MIRROR=$MIRROR_NORM
+ case "$THISARCH" in
+ kfreebsd) DEBIAN_KERNEL="GNU/kFreeBSD";;
+ hurd) DEBIAN_KERNEL="GNU/Hurd";;
+ source) DEBIAN_KERNEL="";;
+ *) DEBIAN_KERNEL="GNU/Linux";;
+ esac
+ export DEBIAN_KERNEL
+
rm -rf $OUT/$THISARCH/*-$TYPE
for file in `cat $UPD/list`